rtorrent支持ipv6的问题

[| 2011/05/14 22:21]
| |
最近想了解一下p2p的东西,于是决定装个rtorrent,rtorrent依赖于libtorrent库。yum源里带的版本太旧,于是决定自己编译一个。

选了rtorrent官网推荐的stable版的libtorrent-0.12.6.tar.gz和rtorrent-0.8.6.tar.gz,编译过程总体比较顺利。期间遇到一个问题,就是我把libtorrent安装到了自己定义的一个路径下,在编译rtorrent的时候用pkg-config搜索libtorrent的时候无法找到。

搜了一下有两个方案,一种是export PKG_CONFIG_PATH="libtorrent的路径",把路径加入pkg-config的搜索路径,是个比较简单的方法。还有一种是定义libtorrent_LIBS环境变量,用来替代pkg-config的输出,比较复杂,不推荐。

编译好后下个bt测试一下,结果发现不能连接tracker服务器,老是timed out。查了下需要libcurl-7.19以上且编译时需要编译时加入c-ares支持,而yum源里最新的是7.15,需要重新编译libcurl,评估了一下代价太大。查了下说0.8.2版以后才有此问题,于是下了个0.8.1版的rtorrent编译了。

在编译rtorrent的时候加了--enable-ipv6,但是实际使用中无法启用ipv6,又查了下发现在编译libtorrent的时候也要加--enable-ipv6.加上后还是不行。后来发现需要给libtorrent打个补丁:

cd libtorrent-0.12.6
wget http://home.samfundet.no/~sesse/libtorrent-0.12.6-ipv6-07.patch
patch -p1 < libtorrent-0.12.6-ipv6-07.patch

然后再configure --enable-ipv6,make,make install。

一切ok。
by snooda | 分类: 默认分类 | 评论(0) | 引用(0) | 阅读(2213)
发表评论
表情
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
打开HTML
打开UBB
打开表情
隐藏
记住我
昵称   密码   游客无需密码
网址   电邮   [注册]